Shopping cart experiencing difficulties with tax connectors.
Incident Report for Matterport
Resolved
This incident has been resolved.
Posted Mar 27, 2020 - 15:01 UTC
Update
We are currently experiencing technical difficulties with our tax connectors, users may see issues when attempting to complete an order. We are investigating the issue.
Posted Mar 27, 2020 - 13:49 UTC
Investigating
We are currently investigating this issue.
Posted Mar 27, 2020 - 13:28 UTC
This incident affected: Shopping Cart.