Add-On Processing delays
Incident Report for Matterport
Resolved
We've identified and rolled out a fix for issues with AddOns. We will repair and process any failed orders for Matterpak, TruePlan, and BIM.
Posted Dec 24, 2021 - 17:41 UTC
Identified
We have identified an issue which may cause delays in processing of Matterpak, TruPlan, and BIM orders. We are working to fix the issue.
Posted Dec 23, 2021 - 18:14 UTC
This incident affected: Add ons.