Shopping cart experiencing difficulties with tax connectors.
Incident Report for Matterport
Resolved
Tax connecter shows services are operational.
Posted Apr 30, 2020 - 22:00 UTC
Investigating
We are currently experiencing technical difficulties with our tax connectors, users may see issues when attempting to complete an order. We are investigating the issue.
Posted Apr 30, 2020 - 20:51 UTC
This incident affected: Shopping Cart.